Handleiding & Help © 2004 - 2007 Russell Phillips

ClamWin programma code © 2004 - 2007 ClamWin Team

Bijgewerkt tot ClamWin Free Antivirus 0.93

www.clamwin.com


Inleiding

ClamWin Free Antivirus is een grafische gebruikersinterface voor de ClamAV anti-virus software die werkt onder Microsoft Windows. De software kan eenvoudig geïnstalleerd worden.

Enkele kenmerken :

  • Scheduler : Stel scans zodanig in dat ze op vaste tijdstippen uitgevoerd worden

  • Automatische updates van de virus database via het Internet

  • Automatische melding van nieuwe ClamWin versies

  • Zelfstandige Virus Scanner

  • Het scannen van programma's die in het computergeheugen geladen zijn

  • Context menu integratie voor de Microsoft Windows Verkenner : klik met je rechter muisknop op een bestand en kies “Scan For Viruses With ClamWin ” om het te scannen

  • Microsoft Outlook add-in die automatisch inkomende en uitgaande emails te scant

Opmerking : ClamWin Free Antivirus heeft geen “on-access realtime” scanner. Dit wil zeggen dat je bestanden manueel moet scannen om een virus te detecteren, ze worden niet automatisch gescand bij het openen of uitvoeren ervan. De Microsoft Outlook Integration Add-in kan echter besmette bijlagen van emails automatisch verwijderen, zonder tussenkomst van de gebruiker.


Installatie Procedure

Download de laatste installatie versie van de ClamWin website . Sluit alle programma’s (vooral Outlook en ClamWin), en voer het setup programma uit. Als er al een versie van ClamWin geïnstalleerd is, kunt u deze gewoon upgraden door de installer van een latere versie uit te voeren. Deze vervangt dan de oude versie door de nieuwe.

Nadat u in het eerste venster op Next hebt geklikt zal de licentieovereenkomst getoond worden. ClamWin Free Antivirus is beschikbaar onder de voorwaarden van de GNU General Public License (GPL). Je moet deze voorwaarden aanvaarden om dit programma te gebruiken. Het installatie programma zal ook binaire bestanden van ClamAntiVirus ( www.clamav.net ) installeren, welke eveneens onder deze voorwaarden beschikbaar zijn.

Vervolgens wordt gevraagd of ClamWin enkel voor u, dan wel voor alle gebruikers van de PC beschikbaar moet zijn. Het wordt aangeraden hier de standaard optie “Anyone who uses this computer (all users)” te kiezen zodat ook ander personen ClamWin kunnen gebruiken.

Daarna zal u gevraagd worden waar u ClamWin wil installeren. De standaard optie is een logische keuze, en deze moet u alleen veranderen als u daarvoor een bepaalde reden hebt.

Vervolgens vraagt de setup welke onderdelen van het programma u wilt installeren.

Twee onderdelen (ClamAV Files en ClamWin Files) zijn uitgegrijsd en moeten altijd worden geïnstalleerd, omdat deze bestanden onmisbaar zijn voor de andere onderdelen om correct te werken.

Integration with Windows Explorer: Als deze optie geselecteerd wordt, zal een extra optie worden toegevoegd in het contextmenu van de Windows Verkenner, zodat bestanden snel en makkelijk via de rechtermuistoets kunnen worden gescand.

Integration with Microsoft Outlook: Als u deze optie selecteert wordt de Outlook add-in geïnstalleerd, die alle inkomende en uitgaande emails automatisch zal controleren. Deze optie zal alleen selecteerbaar zijn als Microsoft Outlook (niet Outlook Express) is geïnstalleerd.

International Help Files: Deze optie heeft een onderverdeling voor de verschillende talen. ClamWin is voorlopig nog niet beschikbaar in vertaalde versies, maar de leden van de gemeenschap hebben al wel vertalingen voorzien van de helpbestanden en/of de handleiding. Het selecteren van de relevante talen installeert deze vertaalde help bestanden en handleidingen.

Na het selecteren van deze opties zal het programma u vragen in welke Startmenu-folder ClamWin's snelkoppelingen moeten geplaatst worden. Standaard wordt een nieuwe folder “ClamWin Antivirus” aangemaakt, en worden de snelkoppelingen daarin geplaatst.

Het volgende scherm vraagt of u de laatste update van de virus database direct na de installatie wilt downloaden van het Internet. Het is aan te raden de virus database zo snel mogelijk op de laatste stand te brengen. Dit scherm geeft u ook de optie om een snelkoppeling op het bureaublad van Windows te plaatsen.

Het laatste scherm toont een samenvatting van de opties die u geselecteerd hebt.

Om ClamWin met deze opties te installeren drukt u nu op Install. Om terug te gaan en de instellingen te wijzigen drukt u op Back.

Als u de optie “Download Virus Database Files” hebt geselecteerd zal deze download direct na de installatie uitgevoerd worden. U moet hiervoor wel verbonden zijn met het Internet.

ClamWin is nu volledig geïnstalleerd en klaar voor gebruik.


Instellingen

Om ClamWin in te stellen kunt u met de rechtermuisknop klikken op het icoon in de System Tray en Configure ClamWin selecteren. U kunt ook van in het hoofdvenster het menu Tools openen en daarin de optie Preferences aanklikken. Er wordt dan een dialoogvenster met negen tabbladen getoond (zie afbeeldingen). Het dialoogvenster sluiten en de veranderingen bewaren doet u door op OK te klikken. Via de Cancel toets sluit u het dialoogvenster zonder de veranderingen te bewaren.

De verschillende tabbladen of pagina's worden in de volgende paragrafen besproken.

Instellingen - Algemeen

Deze pagina instellingen die ClamWin's gedrag bepalen bij het scannen, en die aangeven wat ClamWin moet doen met geïnfecteerde bestanden.

Het kader Scanning Options bepaalt ClamWin's gedrag tijdens het scannen. Elke combinatie van opties is mogelijk. De opties zijn hier als volgt :

  • Display Infected Files Only : Wanneer ClamWin een scan uitvoert worden de namen van de gescande bestanden getoond. Als u echter deze optie selecteert zal ClamWin enkel de namen van besmette bestanden tonen. Hierdoor zou de snelheid in geringe mate verhoogd kunnen worden.

  • Scan In Subdirectories : Vink deze optie aan om ClamWin zowel de bestanden in de gespecificeerde map als die in de onderliggende mappen te laten scannen.

  • Display File Scanned % Progress Indicator : Wanneer deze optie geselecteerd is, zal ClamWin de naam van het bestand tonen dat op dat moment wordt gescand, met de vooruitgang in percentage tussen haakjes. Voor gecomprimeerde bestanden wordt een roterend streepje weergegeven, wat erop duidt dat de scan wel degelijk uitgevoerd wordt.

Het kader Infected Files bevat opties die bepalen welke actie ClamWin moet ondernemen wanneer het een virus detecteert. Hier kan slechts één optie worden gekozen. De opties zijn :

  • Report Only : Wanneer ClamWin een virus vindt zal het dit enkel rapporteren.

  • Remove (Use Carefully): Deze keuze betekent dat ClamWin besmette bestanden voorgoed zal verwijderen. Het bestand wordt niet in de Windows prullenmand geplaatst.

  • Move To Quarantine Folder : In het geval van deze keuze zal ClamWin een besmet bestand verplaatsen naar de opgegeven bestandsmap. Om deze map te veranderen kunt u de locatie ingeven in het ingaveveld, of op de ... knop drukken om de map te zoeken.

    Als er al een bestand met dezelfde naam aanwezig is in de quarantaine map, zal ClamWin een extensie aan de bestandsnaam toevoegen bestaande uit een punt en een volgnummer, zodat het bestaande bestand niet wordt overschreven.
    Bijvoorbeeld : als er een bestand “eicar.com” bestaat in de quarantaine map, dan zal het tweede bestand met dezelfde naam hernoemd worden naar     eicar.com.000. Een derde copy wordt dan eicar.com.001, enzovoort.

    Tot slot is er de optie Unload Infected Programs from Computer Memory. Deze optie bepaalt of ClamWin moet proberen een bestand uit het geheugen te verwijderen als het detecteert dat dit bestand geïnfecteerd is tijdens het uitvoeren van een scan van het geheugen. Deze actie is noodzakelijk om een bestand naar de quarantaine-map te kunnen verplaatsen.

Filters

Via deze pagina kan ClamWin ingesteld worden zodat het enkel bestanden van bepaalde types scant, of zodat het bestanden van bepaalde types zal negeren. Deze twee instellingen kunnen ook gecombineerd worden om een grotere controle te krijgen over de bestandstypen die worden gescand.

Specifieke bestanden kunnen gefilterd worden door de volledige locatie van het bestand in te geven, bijvoorbeeld :

C:\Path\to\folder\File.ext

Mappen kunnen gefilterd worden door de locatie (inclusief *) in te geven. Bijvoorbeeld :

C:\Path\to\folder\*

Let erop dat * niet hetzelfde is als \, dus wanneer u een map met alle submappen wil uitfilteren, zal u een reguliere expressie moeten gebruiken en .* (punt ster) moeten toevoegen op het einde:

<C:\\Path\\to\\folder\\.*>

U kunt reguliere expressies gebruiken voor een grotere flexibiliteit, maar deze moeten dan binnen punthaken geplaatst worden ( <Reguliere expressie> ). U moet ook \\ gebruiken omdat \ een gereserveerd karrakter is. Meer informatie en tutorials over reguliere expressies zijn te vinden op het Internet. Gebruik hiervoor uw favoriete searchengine en zoek op regular expression tutorial.

Standaard worden de volgende bestandstypen uitgesloten van de virus scans :

*.dbx (gebruikt door Microsoft Outlook Express om e-mails en dergelijke te bewaren)

*.tbb (gebruikt door Ritlabs The Bat! om e-mails en dergelijke te bewaren)

*.pst (gebruikt door Microsoft Outlook om gegevens te bewaren)

*.dat

*.log

*.evt

*.nsf

*.ntf

*.chm (Windows help bestanden)

Internet Updates

Op deze pagina kunt u controleren hoe ClamWin updates ophaalt van de virus database.

Enable Automatic Virus Database Updates : Als deze optie is aangevinkt zal ClamWin automatisch controleren of er updates voor de database beschikbaar zijn. U kunt ook instellen hoe vaak dit gecontroleerd moet worden en wanneer.

Wanneer ClamWin niet draait (of de PC uit staat) op het ingestelde tijdstip, zal de update worden uitgevoerd op het eerstvolgende ogenblik wanneer ClamWin wordt gestart (meestal wanneer de PC wordt aangezet). De enige uitzondering hierop is wanneer de update frequentie is ingesteld op “workdays”. In dat geval zal er tijdens het weekend niets gebeuren tot maandag.

Het adres van de server waarvan de updates moeten worden opgehaald kan handmatig ingesteld worden. Meestal zult u hier de standaard instellingen willen behouden ( database.clamav.net ). Indien u echter over een lokale server beschikt die gesynchroniseerd is met database.clamav.net (een zogenaamde mirror), kunt u die server instellen. Voor een lijst van zulke mirrors kunt u terecht op http://www.clamav.net .

Warn if Virus Database is Out of Date: Met deze optie aan zal ClamWin u waarschuwen wanneer uw database niet meer overeenkomt met de laatste stand.

Update Virus Database On Logon : Als deze optie is gekozen, zal ClamWin updates ophalen telkens als een gebruiker zich aanmeldt op de PC.

Notify About New ClamWin Releases: Met deze optie kan u ClamWin automatisch laten controleren of er nieuwe versies van ClamWin vrijgegeven zijn. Deze controle gebeurt 5 minuten na het opstarten van ClamWin, en daarna om de 24 uur.

Proxy

Indien u via een proxy server verbonden bent met het internet, moet u de details van deze verbinding ingeven in dit tabblad. Zoniet, laat dan alle velden leeg. De meeste gebruikers hebben geen proxy nodig, en kunnen deze instellingen gerust negeren.

Geplande Scans

Op deze pagina kunnen scans ingesteld worden zodat deze op gezette tijden uitgevoerd worden. De details van deze geplande taken worden hier getoond. Om een taak toe te voegen klikt u op Add en geeft u een beschrijving, frequentie en tijd in en de map die gescand moet worden.

Een bestaande taak kan aangepast worden door op Edit te klikken en verwijderd worden via de knop Remove.

De geplande taken kunnen geactiveerd of uitgeschakeld worden door op de respectievelijke knop te drukken. Een uitgeschakelde taak zal dan niet op de geplande tijden uitgevoerd worden.

Email Meldingen

U kunt ClamWin zo instellen dat een e-mail rapport wordt gestuurd wanneer een virus wordt gedetecteerd. Selecteer hiervoor de optie Alert On Virus Detection. Vul de benodigde gegevens in om een verbinding te maken met de SMTP server , en de details voor de boodschap (onderwerp, zender en ontvanger).

Opmerking: somige SMTP servers vereisen geen gebruikersnaam en wachtwoord. Indien dit het geval is kunt u deze velden leeg laten.

Om de instellingen te testen klikt u op de knop Send Test Email.

Wanneer deze optie is geselecteerd zal ClamWin een e-mail rapport gestuurd worden telkens wanneer een virus is gevonden. Deze e-mail zal de naam van de computer bevatten vanaf waar de e-mail is gezonden, en een kopie van het scan log bestand.

Archieven (Gecomprimeerde bestanden)

ClamWin kan bestanden in gecomprimeerde bestanden (zoals .zip bestanden) controleren op virussen.

Op deze pagina kunt u instellen of ClamWin al dan niet deze gecomprimeerde bestanden moet controleren. U kunt ook een maximale grootte instellen voor de gecomprimeerde bestanden die moeten worden gecontroleerd, alsook een maximaal aantal bestanden dat moet worden gecontroleerd, en een maximum aantal gecomprimeerde bestanden dat binnenin het bestand moeten worden gecontroleerd.

Scannen binnen gecomprimeerde bestanden kan een scan trager maken, dus deze optie uitschakelen kan de tijd die nodig is per scan verminderen.

Bestandslocaties

Deze pagina laat toe de map te veranderen waarin de ClamScan en FreshClam programmabestanden en de virus database zich bevinden (FreshClam is het programma dat de automatische updates van de virus database verzorgt). Deze gegevens worden ingesteld tijdens de installatie en moeten normaal nooit worden aangepast.

Verander deze gegevens nooit tenzij u weet wat u doet ! Indien ze niet correct zijn zal ClamWin niet meer werken.

Rapporten

Deze pagina laat u toe de mappen en bestandsnamen van de log bestanden te veranderen. De meeste gebruikers zullen dit nooit hoeven aan te passen.

U kunt ook instellen of er pop-up meldingen moeten worden weergegeven via deze pagina. Dit gebeurd reeds bij een standaard installatie. Door de optie Display Pop-up Notification Messages in Taskbar uit te schakelen voorkomt u dat deze pop-ups worden getoond wanneer een virus wordt gedetecteerd, wanneer de virus database is vernieuwd, enzovoort.

Email Scanning

Deze pagina wordt enkel getoond wanneer de add-in voor Microsoft Outlook is geïnstalleerd.

De gebruiker kan hier kiezen of inkomende en/of uitgaande email berichten gescand moeten worden.

Geavanceerd

Deze pagina bevat zes instellingen. Voor de meeste gebruikers zullen de standaard instellingen voldoen.

  • Treat Files As Mailboxes : Wanneer deze optie is aangevinkt zal ClamWin alle bestanden bekijken alsof het MIME e-mail boodschappen waren (bijvoorbeeld Unix/Linux mailboxen, .eml bestanden gegenereerd in Outlook Express, ...). Ook niet-MIME bestanden kunnen met deze optie gescand worden, doch dit zal het scan proces vertragen.

  • Extract Attachments and Macros from MS Office Documens: Met deze optie zal ClamWin MS Office documenten controleren op macrovirussen.

  • Try to Scan Executable Files Only: Met deze optie aan zal ClamWin enkel uitvoerbare programmabestanden controleren.

  • Additional Clamscan Command Line Parameters: Als u extra opties voor ClamScan wil gebruiken die momenteel nog niet door ClamWin worden ondersteund, kan u ze hier toevoegen.

  • Limit Log File Size To: Oude logbestanden zullen indien nodig automatisch gewist worden om de totale grootte van de log bestanden beperkt te houden tot de ingestelde grootte.

  • Scanner Priority: Deze kan ingesteld worden op Low, Normal of High, en bepaalt hoe de totale CPU-tijd wordt verdeeld tussen ClamWin en de andere applicaties op de PC. Deze optie op High zetten kan het scan process versnellen, maar andere applicaties vertragen. Anderzijds zal met deze optie op Low het scan proces vertragen, maar zullen andere applicaties hier minder invloed van ondervinden.


Gebruik

Er zijn verschillende manieren om ClamWin te gebruiken :

  • Uitvoeren vanaf het menu Start

  • Uitvoeren via het icoon in de System Tray

  • Geplande scans

  • MS Outlook integratie

  • Windows Verkenner integratie

Dit hoofdstuk gaat verder in op elke gebruiksmanier

Uitvoeren vanaf het menu Start

Bij een standaard installatie wordt in het Start menu een groep “ClamWin Antivirus” aangemaakt, met daarin één snelkoppeling “Virus Scanner”. Wanneer u hierop klikt zal ClamWin starten met het hoofdvenster, zoals hieronder getoond wordt :

Om een bestand of een map te scannen kunt u deze eenvoudig selecteren in het hoofdvenster, en daarna op Scan drukken. Meerder bestanden en mappen kunnen geselecteerd worden door de Control of de Shift toets ingedrukt te houden terwijl u selecteert.

Om alle programma's te scannen die momenteel in het geheugen geladen zijn kiest u File > Scan Memory. Het scannen van het geheugen kan ook gestart worden via het derde icoon in de toolbar.

Uitvoeren via het icoon in de System Tray

Om ClamWin via het icoon in de System Tray te start kunt u ofwel dubbel-klikken op dit icoon, ofwel het icoon met de rechtermuisknop aanklikken en Open ClamWin selecteren. ClamWin wordt nu gestart met het hoofdscherm, zoals eerder getoond.

Het icoon in de System Tray biedt de volgende opties via de rechtermuisknop :

D ownload Virus Database Update : ClamWin controleert of er updates bestaan voor de virus database, en downloadt deze indien nodig.

Configure ClamWin: ClamWin's instellingen worden getoond zodat deze kunnen worden veranderd.

Scheduler: Dit item bevat een submenu waarmee geplande scans kunnen worden ingesteld, uitgevoerd of gestopt.

Display Reports: Dit item bevat een submenu waarmee het rapport van de virus database updates of het scan rapport kan worden bekeken.

Check Latest Version: Hiermee opent u in uw standaard browser een pagina van de ClamWin site die de geïnstalleerde versie van ClamWin controleert. De pagina toont de nieuwste beschikbare versie, en of deze al dan niet is geïnstalleerd. Tevens wordt een link naar de download pagina getoond, zodat u indien nodig een nieuwere versie kunt ophalen.

Visit ClamWin Website: Hiermee opent u de ClamWin website in uw standaard browser.

Geplande Scans

Geplande scans kunnen ingesteld worden via het instellingen venster (Tools > Preferences > Scheduled Scans) of vanaf het icoon in de system tray (Scheduler > Configure Scheduler). Wanneer een scan is gepland zal ClamWin deze scan uitvoeren op de ingestelde tijd, zonder de gebruiker hiervoor te onderbreken. Als een virus gevonden wordt zal een ballonmelding verschijnen boven het icoon in de system tray (opmerking : dit werkt niet in Windows 98). De actie die ClamWin moet ondernemen bij het detecteren van een virus wordt bepaald in het tabblad General van het instellingenvenster.

MS Outlook Integratie

Als MS Outlook op de computer geïnstalleerd is, wordt tijdens de installatie van ClamWin de optie “Integration with Microsoft Outlook” getoond. Indien u deze optie aankruist zal een addin worden toegevoegd aan Outlook die alle emails controleert op virussen alvorens u deze opent. Deze controle gebeurd automatisch, zonder tussenkomst van de gebruiker. Als een inkomende e-mail een virus bijlage bevat, wordt deze bijlage vervangen door een rapport.

Windows Verkenner Integratie

Bij het installeren van ClamWin kan u de optie “Integration with Windows Explorer” selecteren. ClamWin voegt dan een extra optie (Scan for Viruses With ClamWin) toe in het Windows Verkenner context menu. Zo kunt u door met de rechtermuisknop op een verdacht bestand of een map te klikken dit bestand of deze map scannen.


Geavanceerd gebruik

Dit hoofdstuk bevat een aantal details voor de meer ervaren gebruikers.

ClamWin's standaard configuratie aanpassen

Wanneer er een bestand met de naam clamwin.conf in de map bewaard is waarin de ClamWin programmabestanden zich bevinden ("C:\Program Files\ClamWin\bin" bij een standaard installatie), zal ClamWin de inhoud van dit bestand overnemen als de standaard configuratie bij de eerste maal dat iemand ClamWin uitvoert.

Wanneer u meerdere nieuwe gebruikers accounts aanmaakt op een PC, of wanneer u net ClamWin hebt geïnstalleerd op een systeem met meerdere gebruikers, is het aan te raden dat u een default configuratie aanmaakt en het bestand clamwin.conf naar deze map copiëert.

Een Virus Scan uitvoeren vanaf de Command Line

ClamWin kan uitgevoerd worden vanaf de command line (“DOS box”), bijvoorbeeld vanuit een batch bestand. Om een volledige lijst van de parameters te bekijken kunt u naar de map met de programmabestanden gaan ("C:\Program Files\ClamWin\bin" bij een standaard installatie) en het volgende commando uitvoeren :

clamscan.exe --help

De database locatie moet gespecifiëerd worden door gebruik te maken van de parameter --database=FILE/DIR. Bij een standaard installatie is het commando om de volledige C: partitie te scannen bijvoorbeeld :

clamscan.exe --database="C:\Program Files\ClamWin\db" --recursive C:\

Merk op dat u best de parameter --recursive gebruikt om zeker te zijn dat de sub-mappen ook worden gescand.

Wanneer ClamWin wordt uitgevoerd vanaf de command line zal een waarde worden teruggegeven die aanduidt of er al dan niet een virus is gevonden. Wanneer geen virus is gevonden is de teruggegeven waarde 0. Is er wel een virus gevonden, dan is deze waarde 1. Elke andere waarde geeft een fout aan.

De Virus Database vernieuwen vanaf de command line

ClamWin gebruikt het programma freshclam.exe om de virus database te vernieuwen. Net als het scanprogramma clamscan.exe kan ook freshclam uitgevoerd worden vanaf de command line, vanaf batch bestanden, enzovoort.

Om een volledige lijst van de parameters te bekijken navigeert u naar de map met de programmabestanden ("C:\Program Files\ClamWin\bin" bij een standaard installatie) en voert u het volgende commando uit :

freshclam.exe --help

Zowel de map met de database als de plaats van het configuratie bestand moeten gespecifiëerd worden. ClamWin genereert een freshclam configuratie bestand enkel op het moment dat dit nodig is, dus u zal uw eigen bestand moeten samenstellen. Dit configuratiebestand is een tekstbestand. Bekijk de ClamAV documentatie voor de volledige details van de mogelijke instellingen. Een eenvoudig freshclam configuratiebestand zou de volgende regels bevatten (lijnen die met # beginnen zijn commentaar) :

# URL of server where database updates are to be downloaded from
# If this option is given multiple times, each will be tried in
# the order given until an update is successfully downloaded

DatabaseMirror database.clamav.net

# Number of times to try each mirror before moving to the next one

MaxAttempts 3

Wanneer u éénmaal een configuratie bestand hebt aangemaakt kunt u freshclam uitvoeren met een opdracht zoals de volgende :

freshclam --datadir="C:\Documents and Settings\All Users\.clamwin\db" --config-file="C:\Program Files\ClamWin\bin\freshclam.conf"

Updates afhalen van een lokale server

Als u ClamWin geïnstalleerd hebt op meerdere computers in een netwerk is het misschien wenselijk om één computer de updates van het internet te laten afhalen, terwijl de andere computers de updates over het locale netwerk van deze server afhalen. Dit is mogelijk op de volgende manier:

Zet een web server op die de bestanden main.cvd en daily.cvd in zijn web root map heeft. Het moet mogelijk zijn om deze bestanden naar de client computers te downloaden door via een webbrowser naar http://UWSERVER//main.cvd en http://UWSERVER/daily.cvd te gaan.

In de ClamWin instellingen van de client computers op het tabblad Internet Updates geeft u het IP address of de domeinnaam van de web server in in het veld Download Site. Geef niets meer in dan het IP adres of de domeinnaam (bijvoorbeeld 192.168.1.1.is correct, maar http://192.168.1.1/ is fout). ClamWin zal dan de lokale webserver benaderen voor updates, in de plaats van de internet server.

De bestanden zijn beschikbaar op www.clamav.net. U kan een batch script maken dat automatisch deze bestanden download naar de web root van uw server met een tooltje als wget, als volgt:

wget http://%DB_MIRROR%/main.cvd -O "%WEBROOT%\main.cvd"

wget http://%DB_MIRROR%/daily.cvd -O "%WEBROOT%\daily.cvd"

Merk hierbij op dat differentiële updates momenteel niet mogelijk zijn. Hiervoor zou u een mirror moeten opzetten van database.clamav.net, doch dit wordt momenteel niet ondersteund voor privé gebruik.

Handmatig bijwerken van de Virus Database

Als u de virus database handmatig wil updaten, moet u de virus database files main.cvd en daily.cvd downloaden en copiëren naar ClamWin's virus database map, waarbij u de bestaande bestanden overschrijft. De virus database files kunnen gedownload worden vanaf ClamAV's homepage op www.clamav.net


FAQ: Vaak gestelde vragen

Raadpleeg aub de online FAQ op http://nl.clamwin.com/content/category/3/7/27/


Problemen Oplossen

Dit hoofdstuk bespreekt oplossingen voor de volgende problemen:

        • Wanneer ik probeer een test e-mail alarm te verzenden, verschijnt de volgende boodschap

        • E-mail programma's die boodschappen in een enkel bestand bewaren

        • Conflicten met ActivePython

        • Outlook hersteld zich niet na het minimaliseren

Als uw probleem hier niet bij is, kijk dan even op de FAQ op: http://www.clamwin.com/content/category/3/7/27/

Probleem : Wanneer ik probeer een test e-mail alarm te verzenden, verschijnt de volgende boodschap :

Kan geen email verzenden. Gelieve uw internet verbinding na te kijken. Error: SMTP instance has no attribute 'sock'

of :

Kan geen email verzenden. Gelieve uw internet verbinding na te kijken. Error: SMTP AUTH extension not supported by server

Oplossing : De instellingen voor de SMTP server zijn niet juist. Let hierbij op : ISP's vragen meestal geen naam & passwoord voor de SMTP server. Laat deze velden dan ook leeg.

E-mail programma's die boodschappen in een enkel bestand bewaren

Sommige e-mail programma's (zoals The Bat! ) slaan alle boodschappen op in één enkel bestand. Andere gebruiken voor elke e-mail een apart bestand. Wanneer ClamWin een virus vind dat als bijlage bij een e-mail zit, zal het het volledige bestand (dus alle e-mails in dat bestand) als geïnfecteerd beschouwen. Bijgevolg zal het volledige bestand verwijderd worden naar de quarantaine map. U kunt de filterinstellingen aanpassen (zie de instructies voor configuratie) zodat dit bestand niet wordt gescand.

Indien u The Bat! gebruikt is het interessant voor u om te weten dat Marco Pontello een plug-in heeft geschreven waardoor The Bat! ClamWin kan gebruiken om bijlagen te scannen. Meer details hierover vindt u op Marco's web site .

Conflicten met ActivePython

In principe is er geen probleem wanneer u python 2.3 and pywin32-201 ( http://sourceforge.net/projects/pywin32/ ) hebt geïnstalleerd.

Blijkbaar is er wel een probleem met versies van ActiveState python met win32all-163 (nu pywin32), die een dll conflict veroorzaken. Als u dus ActivePython 2.3 gebruikt, installeer dan gewoon pywin32 en het probleem zou opgelost moeten zijn.

Outlook hersteld zich niet na het minimaliseren

Wanneer ClamWin is geïnstalleerd zou het kunnen dat Outlook 2000 zich niet hersteld nadat het geminimaliseerd is en weer geopend wordt. Het installeren van de Office 2000 Service Release 1a (SR1a) lost dit probleem op. Deze service release is ook in het algemeen aan te raden omdat deze een aantal bugfixes en security fixes bevat. De volledige details en downloads vind u op http://www.microsoft.com/downloads/details.aspx?FamilyID=AF6C8D03-7633-45B4-AB96-795EE656F2A2&displaylang=EN of op http://tinyurl.com/xsyx .


ClamWin CD/USB - HowTo

Bijlage A : ClamWin uitvoeren vanaf CD of USB drive

Inleiding

Deze tutorial toont hoe u een CD of USB drive kan voorzien van een kopie van ClamWin , zodat u een Windows PC kunt scannen op virussen zonder ClamWin op de PC te installeren. Merk hierbij op dat de CD of USB drive niet bootable is, en dus enkel kan gebruikt worden op een werkend Windows systeem.

Op de PC die gebruikt wordt om de CD of USB drive aan te maken moet ClamWin geïnstalleerd zijn, en deze moet natuurlijk ook bestanden en mappen kunnen copiëren op CD of USB drive.

De gemakkelijke manier: Portable ClamWin

Het makkelijkste kunt u de voor u gemaakt “draagbare” versie van ClamWin gebruiken, die u kan vinden op http://portableapps.com/apps/utilities/clamwin_portable .

Let wel: de personen die deze Portable ClamWin onderhouden zijn niet verbonden met het ClamWin team, en daarom kan het team u niet altijd helpen wanneer u problemen met deze versie ondervindt. Daarenboven kan het zijn dat ClamWin Portable één of meerdere versies achterloopt op de officiële ClamWin releases.

Voorbereiding

Begin met het installeren van de laatste beschikbare versie van ClamWin, en download ook de laatste virus database. Zie de ClamWin manual voor de details over hoe u dit kunt doen.

Wanneer u een CD creëert, zult u daarna niet meer de virus database op de CD kunnen vernieuwen zonder een nieuwe CD te maken.

Copiëer de mappen

Creëer ergens een tijdelijke map op een makkelijke plaats op de harde schijf om de bestanden in op te slaan die naar de CD of USB drive moeten worden gekopieerd, bijvoorbeeld C:\ClamWin-CD.

In deze map creëert u een map met de naam ClamWin.

Kopieer de inhoud van de ClamWin programmamap (standaard c:\Program Files\clamwin) naar deze ClamWin map.

Create folders named log, db and quarantine in C:\ClamWin-CD\ClamWin

Creëer tevens mappen met de namen log, db en quarantine in c:\ClamWin-CD\ClamWin.

Kopieer de ClamWin database bestanden (alle bestanden in de db map) naar C:\ClamWin-CD\ClamWin\db. In Windows 2000/Xp staat deze ClamWin database map standaard op c:\Documents and settings\USERNAME\.clamwin\db (USERNAME is daarbij uw login naam) of in c:\documents and settings\All Users\.clamwin\db.

Kopieer de volgende tekst naar een tekstbestand met de naam C:\ClamWin-CD\ClamWin\bin\clamwin.conf:

[Schedule]
path = .\

[ClamAV]
clamscan = .\clamscan.exe
enablembox = 0
maxfiles = 500
infectedonly = 0
database = ..\db
includepatterns =
scanole2 = 1
excludepatterns = *.dbx|CLAMWIN_SEP|*.tbb|CLAMWIN_SEP|*.pst|CLAMWIN_SEP|*.dat|CLAMWIN_SEP|*.log|CLAMWIN_SEP|*.nsf|CLAMWIN_SEP|*.ntf|CLAMWIN_SEP|*.chm
maxsize = 10
scanarchives = 1
priority = Low
maxrecursion = 5
maxlogsize = 1
moveinfected = 0
debug = 0
logfile = ..\log\ClamScanLog.txt
scanrecursive = 1
freshclam = .\freshclam.exe
quarantinedir = ..\quarantine
removeinfected = 0

[UI]
reportinfected = 1
traynotify = 0
standalone = 1

[Updates]
dbupdatelogfile = ..\log\ClamUpdateLog.txt
enable = 1
dbmirror = database.clamav.net
updateonlogon = 0
frequency = Daily
weekday = 2
time = 12:00:00

[EmailAlerts]
enable = 0
from = clamwin@yourdomain
to = admin@yourdomain
smtppassword =
smtpuser =
smtphost =
smtpport = 25
subject = ClamWin Virus Alert

[Proxy]
host =
password =
port = 3128
user =

U zou nu de volgende mappen moeten hebben :

C:\ClamWin-CD
C:\ClamWin-CD\ClamWin\bin
C:\ClamWin-CD\ClamWin\db
C:\ClamWin-CD\ClamWin\lib
C:\ClamWin-CD\ClamWin\quarantine

Kopiëer de bestanden naar de CD/USB

U moet nu enkel de inhoud van de map c:\clamwin-cd kopiëren naar de CD of USB drive. Kopieer niet de map c:\ClamWin-CD zelf, maar enkel de inhoud. Hoe dit precies moet gedaan worden hangt ervan af of u een CD of een USB drive gebruikt, en natuurlijk ook van welke software u gebruikt.

Gebruik van de CD/USB

Om deze cd of USB drive te gebruiken plaatst u deze in de PC die moet worden gescand. Voer ClamWin uit door te dubbelklikken op het bestand ClamWin.exe in de map ClamWin\bin.

ClamWin zou normaal moeten werken, maar heeft in geval van een CD (die u enkel kunt lezen en niet kunt schrijven) de volgende beperkingen :

  • Bestanden worden niet in quarantaine geplaatst

  • Internet updates zullen niet werken

  • De instellingen kunnen niet aangepast worden

Deze beperkingen zijn niet van toepassing op een USB drive waarop u lees- en schrijfrechten hebt.


GNU GENERAL PUBLIC LICENSE

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.

59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change free software - to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

GNU General Public License Terms and Conditions for Copying, Distribution and Modification

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term "modification".) Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

No Warranty

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is found.

<one line to give the program's name and a brief idea of what it does.> Copyright (C) <year> <name of author>

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'. This is free software, and you are welcome to redistribute it under certain conditions; type `show c' for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, the commands you use may be called something other than `show w' and `show c'; they could even be mouse-clicks or menu items - whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program `Gnomovision' (which makes passes at compilers) written by James Hacker.

<signature of Ty Coon>, 1 April 1989 Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Library General Public License instead of this License.


Nederlandse vertaling van de GNU GENERAL PUBLIC LICENSE

English disclaimer

This is an unofficial translation of the GNU General Public License into Dutch. It was not published by the Free Software Foundation, and does not legally state the distribution terms for software that uses the GNU GPL--only the original English text of the GNU GPL does that. However, we hope that this translation will help Dutch speakers understand the GNU GPL better.

Nederlandse waarschuwing

Dit is een niet officiële vertaling van de GNU Algemene Publieke Licentie in het Nederlands. Deze licentie is niet gepubliceerd door de Free Software Foundation, de condities van software onder de GPL hieronder zijn niet rechtsgeldig. Enkel de originele Engelse tekst van de GNU GPL bevat geldige richtlijnen. Daarentegen hopen we dat deze vertaling de Nederlandstaligen helpt om de GNU GPL beter te begrijpen.

Auteursrecht (C) 1989, 1991 Free Software Foundation, Inc.59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Het is eenieder toegestaan om dit licentiedocument te kopiëren en er letterlijke kopieën van te verspreiden, er wijzigingen in maken is echter niet toegestaan.

Voorwoord

De licenties van de meeste software zijn zo opgesteld om U het recht
te ontnemen om die software te delen en te wijzigen. Hier tegenover
staat de GNU Algemene Publieke Licentie, die bedoeld is om U de
vrijheid te garanderen dat U de software kunt
delen en wijzigen -- om er zeker van te zijn dat de software
vrij is voor alle gebruikers. Deze Algemene Publieke Licentie is van
toepassing op het merendeel van de Free Software Foundation's
software en van alle andere programma's waarvan de auteur ze plaatst
onder deze licentie. (Sommige software van de Free Software
Foundation is gedekt door de GNU Algemene Minder
Publieke Licentie). U kunt deze ook toepassen op uw eigen
programma's.

Wanneer we het hebben over vrije software, dan
hebben we het over vrijheid, niet prijs. Onze Algemene Publieke
Licentie laat u toe om kopieën te verspreiden van vrije
software (en dat U geld kunt vragen voor deze dienst) en dat U er de
broncode van hebt of kunt krijgen als U dat wenst, dat U de software
kunt wijzigen of er delen van kunt gebruiken in nieuwe vrije
programma's en dat U weet dat U deze dingen kunt doen.

Om deze rechten te beschermen, moeten we verbieden
dat iemand U deze rechten ontzegt of vraagt deze op te geven. Deze
restricties brengen enkele verantwoordelijkheden mee indien U kopieën
van de software verspreidt of de software wijzigt.

Bijvoorbeeld, als U kopieën van zulk
programma verspreidt, kostenloos of voor een vergoeding, dan moet U
de personen die de software ontvangen al de rechten geven die U hebt.
U moet uzelf ervan verzekeren dan ook zij de broncode ontvangen of
kunnen verkrijgen. U moet hen ook deze licentie tonen zodat ze hun
rechten kennen.

 We beschermen uw rechten met twee stappen

(1) de software wordt auteursrechtelijk beschermd,
en

(2) we bieden U deze licentie die U de legale
toestemming geeft om de software te kopiëren, te verspreiden
en/of te wijzigen.

Alsook willen we voor de bescherming van de auteur
en onszelf iedereen ervan verzekeren dat er geen garantie is voor
deze vrije software. Als de software gewijzigd is door iemand anders
en doorgegeven, dan willen we dat de ontvanger weet dat wat ze
ontvangen hebben niet het origineel is, zodat problemen veroorzaakt
door anderen geen effect hebben op de reputatie van de
oorspronkelijke auteur.

Ten laatste, elk vrij programma wordt voortdurend
bedreigd door software patenten. We wensen het gevaar te vermijden
dat de verdelers van een vrij programma uiteindelijk een patent
verkrijgen op het programma en het daarmee in eigendom van een
particulier brengen. Om dit te vermijden, hebben we het duidelijk
gemaakt dat elk patent in licentie gegeven moet zijn voor eenieders
vrij gebruik, oftewel helemaal niet in licentie gegeven mag zijn.

De exacte bepalingen en condities om te kopiëren,
verspreiden en wijzigen volgen hieronder.

GNU ALGEMENE PUBLIEKE LICENTIE : BEPALINGEN EN
VOORWAARDEN OM TE KOPIËREN, VERSPREIDEN EN WIJZIGEN

0.  Deze licentie is van toepassing op elk programma of ander werk
dat een notie bevat van de eigenaar die zegt dat het verspreid mag
worden onder de bepalingen van deze licentie. Het "Programma",
verder in de tekst, verwijst naar eender zulk programma of werk, en
een "werk gebaseerd op het programma" verwijst naar het
Programma of eender welk ander afgeleid werk onder de wet van het
auteursrecht: dit wil zeggen, een werk dat het Programma of een deel
ervan bevat, letterlijk oftewel gewijzigd en/of vertaald naar een
andere taal. (Hierna vallen vertalingen zonder beperking onder de
term "wijziging".)

Elke licentiehouder wordt geadresseerd als "u".

Andere handelingen dan kopiëren, verspreiden
en wijzigen zijn niet gedekt door deze licentie; hiervoor is deze
licentie niet bedoeld. De handeling om het Programma uit te voeren is
niet gelimiteerd, en de uitvoer van het Programma is enkel gedekt als
de inhoud bestaat uit een werk gebaseerd op het Programma
(onafhankelijk of deze uitvoer gemaakt is door het Programma uit te
voeren). Of dit waar is hangt af van wat het Programma doet.

1.  U mag letterlijke exemplaren verspreiden van
de programma broncode en deze kopiëren zoals U deze ontvangt, in
eender welke vorm, op voorwaarde dat U ervoor oplet dat U op elke
kopie de gepaste auteursrechten en afwijzing van garantie vermeldt;
hou alle referenties naar deze licentie en naar het ontbreken van
garantie intact ;en geef aan elke andere ontvanger van het Programma
een kopie van deze licentie, bijgevoegd bij het Programma.

U mag een honorarium vragen voor de fysische daad
van het afleveren van een kopie, en U mag indien U dat wenst een
garantie bescherming bieden voor een honorarium.

2.  U mag uw kopie of kopijen van het Programma,
of een deel van het Programma, wijzigen, daarbij een werk gebaseerd
op het Programma vormend. U mag deze wijzigingen kopiëren en
verspreiden onder de bepalingen van Paragraaf 1 hierboven, indien U
ook aan al deze voorwaarden voldoet:

a) U moet in de gewijzigde bestanden duidelijk
vermelden dat U het bestand gewijzigd hebt en de datum waarop U dat
gedaan hebt.

b) U moet elk werk dat U publiceert of verspreidt
en dat volledig of gedeeltelijk bestaat uit het Programma, of daarvan
een afgeleid werk is, als een geheel in licentie geven, zonder
kosten, aan alle derde partijen onder de bepalingen van deze
Licentie.

c) Indien het gewijzigde Programma normaal gezien
interactief parameters inleest, dan moet U er voor zorgen dat wanneer
het Programma zonder deze parameters gestart wordt, het een boodschap
weergeeft met een gepast auteursrechtbericht en een mededeling dat er
geen garantie is (of anders, dat U een garantie voorziet) en dat
gebruikers het Programma mogen verspreiden onder deze voorwaarden. De
boodschap moet de gebruiker ook duidelijk maken hoe hij een kopij
van deze Licentie kunt bekijken. (Uitzondering : als het Programma
zelf interactief is en normaal geen boodschap toont, dan is
het niet vereist dat uw werk gebaseerd op dit Programma zulk een
boodschap weergeeft.

Deze vereisten zijn van toepassing op het werk als
een geheel. Als herkenbare stukken van dat werk niet afgeleid zijn
van het Programma, en redelijkerwijs onafhankelijk beschouwd kunnen
worden, dan is deze licentie, en zijn bepalingen, niet van toepassing
op die delen als U die als aparte werken verspreidt. Maar als U die
zelfde delen verspreidt als deel van een geheel dat een werk is
gebaseerd op het Programma, dan moet de verspreiding van het geheel
op de bepalingen van deze licentie geschieden, dewelke's vergunningen
voor andere licentiehouders zich uitbreiden tot het volledige geheel,
en dus tot elke deel van het werk, onafhankelijk van wie het
geschreven heeft.

Dus, het is niet de bedoeling van deze sectie om
uw rechten op te eisen of te wedijveren om uw rechten op werk dat
geheel door uzelf geschreven is, het is eerder de bedoeling het recht
controle uit te oefenen mogelijk te maken op de verspreiding van
afgeleide of collectieve werken gebaseerd op het Programma.

Daarenboven, de bundeling van een werk niet
gebaseerd op het Programma met het Programma (of met een werk
gebaseerd op het Programma) op een opslagmedium of
verspreidingsmedium brengt het ander werk niet onder deze licentie.

3.  U mag het Programma, of een werk gebaseerd op
het Programma, zie paragraaf 2, verspreiden en kopiëren, in
binaire of uitvoerbare vorm onder de bepalingen van paragraaf 1 en 2
hierboven, op voorwaarde dat U aan een van de volgende voorwaarden
voldoet :

a) Voeg een volledige overeenkomende broncode bij,
leesbaar door computers, verspreid onder de bepalingen van de
paragrafen 1 en 2, op een medium dat gebruikelijk is voor het
uitwisselen van software; of,

b) Voeg een voor minstens 3 jaar geldige,
geschreven, offerte bij, om de complete overeenstemmende broncode, op
een medium dat hiervoor gebruikelijk is, voor Computers leesbaar,
verspreidbaar onder de bepalingen van de paragrafen 1 en 2 hierboven,
aan elke derde partij te leveren, voor een vergoeding die niet meer
bedraagt dan de kost om de broncode te kopiëren.

c) Voeg de informatie bij die U ontving
betreffende het aanbod om de bijpassende broncode te verkrijgen. (Dit
alternatief is enkel toegestaan voor niet commerciële
verspreiding en enkel als U het programma in binaire of uitvoerbare
vorm ontving met zulk een aanbod, in overeenstemming met subparagraaf
b erboven.) De broncode van een werk is de vorm van het werk waaraan
voorkeur wordt gegeven om er wijzigingen in aan te brengen. Voor een
uitvoerbaar werk betekent volledige broncode alle code van alle
modules waar het werk uit bestaat, en daarbovenop alle definitie
bestanden van de interface(s) en alle scripts om het programma te
compileren en het uitvoerbare bestand te installeren. Als een
speciale uitzondering moet de verspreidde broncode niets bevatten dat
normaal verspreid (in broncode of uitvoerbare vorm ) wordt met de
hoofdcomponenten (compiler, kernel, enz...) van het besturingssysteem
op dewelke het Programma draait, tenzij die component bij het
uitvoerbare bestand zit.

Als verspreiding van een uitvoerbaar bestand of
binaire code mogelijk gemaakt wordt door toegang tot het kopiëren
van een vooraf bepaalde plaats, dan telt het mogelijk maken de
broncode van diezelfde plaats te kopiëren als het verspreiden
van de broncode, zelfs indien het mee kopiëren van de broncode
optioneel is.

4.  U mag het Programma niet kopiëren,
wijzigen, verder in licentie geven of verspreiden behalve zoals
expliciet vermeld in deze licentie. Eender welke poging om het
programma op een andere manier te kopiëren, wijzigen, verder in
licentie geven of verspreiden is ongeldig en verklaart automatisch uw
rechten bepaald in deze licentie nietig. Derde partijen die kopieën
of rechten van U hebben ontvangen onder deze licentie blijven hun
rechten behouden zolang ze de voorwaarden niet schenden.

5.  U bent  niet verplicht deze
licentieovereenkomst te accepteren, aangezien U deze niet ondertekend
hebt. Echter, niets anders geeft U de toestemming om het Programma of
werken gebaseerd op het Programma te wijzigen of te verspreiden. Deze
daden zijn door de wet verboden als U deze licentieovereenkomst niet
accepteert. Daarom geeft u aan dat door het Programma te verspreiden
of te wijzigen, U deze licentie, en al zijn voorwaarden en bepalingen
in verband met kopiëren, wijzigen of verspreiden van het
Programma, of werken gebaseerd op het Programma, accepteert om dat te
kunnen doen.

6.  Elke keer U het Programma (of een werk
gebaseerd op het Programma) verspreidt, krijgt de ontvanger
automatisch een licentie van de originele licentiehouder om het
Programma te kopiëren, verspreiden of wijzigen, onderworpen aan
deze bepalingen en voorwaarden. U mag de ontvanger geen beperkingen
opleggen om de rechten uit te oefenen die hierin bepaald zijn.

7.  Als door gevolg van een rechterlijke uitspraak
of beweringen van patentenschending of door eender welke andere reden
(niet beperkt tot  patentenproblemen) U bepalingen worden opgelegd
(door rechterlijk bevel, overeenkomst, of op andere wijze) die in
tegenspraak zijn met bepalingen in deze licentie, dan sluit dat U
niet uit om aan de voorwaarden van deze licentie te voldoen.
Als U het Programma niet kunt verspreiden en daarbij zowel aan
tegelijk de bepalingen van deze licentie als aan andere relevante
verplichtingen kunt voldoen, dan mag U als gevolg daarvan het
Programma helemaal niet verspreiden. Bijvoorbeeld, als een patent
licentieovereenkomst niet zou toestaan dat het

programma zonder het betalen van royalty's vrij
verspreid mag worden door zij die het Programma direct van U
verkrijgen en zij die het indirect door U verkrijgen, dan is de enige
manier om zowel daaraan als aan deze licentie te voldoen dat U zich
compleet onthoudt van het verspreiden van het Programma.

Als een deel van dit artikel ongeldig wordt
geacht, of het kan niet afgedwongen worden onder bepaalde
omstandigheden dan is het de bedoeling dat het overwicht van dit
artikel van toepassing is. In andere omstandigheden geldt dit artikel
volledig.

Het is niet het doel van dit artikel om u er toe
aan te zetten om patenten, of andere aanspraken van bezit, te
schenden of de geldigheid van zulke aanspraken aan te vechten. Het
enige doel van dit artikel is om de integriteit te beschermen van het
vrije software verspreidingssysteem, dat wordt toegepast door middel
van Publieke Licentie praktijken. Veel mensen hebben royale bijdragen
geleverd aan het systeem van vrije software rekenend op de
betrouwbaarheid van zijn toepassing. Het is aan de auteur/donor om te
bepalen of hij of zij bereidt is om software te verspreiden door
middel van een ander systeem en een gelicensieerde kan die keuze niet
afdwingen.

Dit artikel is bedoeld om zeer duidelijk te maken
wat geloofd wordt een gevolg te zijn van de rest van deze licentie.

8. Als de verspreiding of het gebruik van het
Programma gelimiteerd is in bepaalde landen, door patenten of door
samenwerking van auteursrechthouders, dan mag de oorspronkelijke
auteursrechthouder die het Programma onder deze licentie plaatste een
expliciete geografische beperking toevoegen zodat verspreiding enkel
toegestaan is in of tussen landen die niet uitgesloten zijn. In dat
geval bevat deze licentie de beperking alsof ze in de kern van deze
licentie geschreven was.

9.  De Free Software Foundation mag gereviseerde
en/of nieuwe versies van de Algemene Publieke Licentie uitbrengen van
tijd tot tijd. Zulke nieuwe versies zullen gelijkaardig in karakter
zijn in vergelijking met de huidige versie maar kunnen in details
verschillen om nieuwe problemen of aangelegenheden te behandelen.
Elke versie krijgt een expliciet versienummer mee. Als het Programma
een versie van deze licentie specificeert waarop het van toepassing
is en "elke volgende versie", dan hebt U de keuze om de
bepalingen en voorwaarden van die licentie te volgen, of van eender
welke versie die later uitgegeven werd door de Free Software
Foundation. Als het programma geen versie nummer
van de licentie specificeert, dan mag U de bepalingen en
voorwaarden volgen van eender welke versie ooit uitgegeven door de
Free Software Foundation.

10.  Indien U delen van het Programma wil invoegen
in andere vrije Programma's dewelke's verspreidingsvoorwaarden anders
zijn, dan moet U de auteur van dat programma om toestemming vragen.
Voor software waarvan het auteursrecht bij de Free Software
Foundation rust, schrijf naar de Free Software Foundation; we maken
hier soms uitzonderingen op. Onze beslissing zal geleid worden door
onze twee hoofddoelen om de vrije status van de afgeleiden van onze
vrije software te vrijwaren en om het delen en hergebruiken van
software in het algemeen te promoten.

11.  OMDAT HET PROGRAMMA ZONDER KOSTEN IN LICENTIE
GEGEVEN WORDT, IS ER GEEN GARANTIE VOOR HET PROGRAMMA, VOOR ZOVER
MOGELIJK BINNEN DE GELDENDE WETGEVING. UITGEZONDERD WANNEER HET
EXPLICIET GESCHREVEN STAAT LEVEREN DE AUTEURSRECHTHOUDERS HET
PROGRAMMA "ZOALS HET IS", ZONDER EENDER WELKE GARANTIE,
EXPLICIET UITGEDRUKT OF IMPLICIET BEDOELD, ZOALS, MAAR NIET
GELIMITEERD TOT, DE IMPLICIETE GARANTIES VAN VERKOOPBAARHEID EN
GESCHIKTHEID VOOR EEN BEPAALD DOEL. HET VOLLEDIGE RISICO BETREFFENDE
DE KWALITEIT EN DE PRESTATIES VAN HET PROGRAMMA LIGT BIJ U. MOCHT HET
PROGRAMMA DEFECT BLIJKEN DAN DRAAGT U DE KOSTEN VAN ALLE BENODIGDE
DIENSTEN, REPARATIES OF CORRECTIES.

12.  IN GEEN ENKEL GEVAL, TENZIJ VEREIST DOOR DE
GELDENDE WET, OF SCHRIFTELIJK OVEREENGEKOMEN ZAL DE
AUTEURSRECHTHOUDER, OF EENDER WELKE DERDE PARTIJ DIE HET PROGRAMMA
MAG WIJZIGEN EN/OF VERSPREIDEN ZOALS TOEGESTAAN HIERBOVEN,
VERANTWOORDELIJK KUNNEN WORDEN GEACHT TEGENOVER U BETREFFENDE
ALGEMENE, SPECIALE, UITZONDERLIJKE OF RESULTERENDE SCHADE DIE
VOORTVLOEIT UIT HET GEBRUIK, OF DE ONKUNDIGHEID OM HET PROGRAMMA TE
GEBRUIKEN (INCLUSIEF, MAAR NIET GELIMITEERD TOT HET VERLIES VAN
GEGEVENS, GEGEVENS DIE CORRUPT WORDEN, OF VERLIEZEN GELEDEN DOOR U OF
DERDE PARTIJEN OF EEN FALING VAN HET PROGRAMMA OM SAMEN TE WERKEN MET
ANDERE PROGRAMMA'S), ZELFS INDIEN DE AUTEURSRECHTHOUDER OF EEN ANDERE
PARTIJ GEÏNFORMEERD WAS OVER DE MOGELIJKHEID TOT ZULKE SCHADE.

EINDE VAN DE BEPALINGEN EN VOORWAARDEN

Hoe deze bepalingen op uw nieuwe Programma's
toepassen.

Als U een nieuw Programma ontwikkelt en U wenst dat het van het
grootst mogelijk nut is voor iedereen, dan is de beste manier om dit
te bereiken door het Programma vrije software te maken dewelke
iedereen kan verspreiden en wijzigen onder deze bepalingen.

Om dit te doen, voeg volgende boodschap toe aan
het Programma. Het is het veiligst om ze in te voegen aan het begin
van elk bronbestand, dit om het ontbreken van garantie duidelijk te
maken; en elk bestand zou minstens de "auteursrecht" lijn
en een directief naar waar de volledige boodschap gevonden kan worden
moeten bevatten.

<een regel voor de naam van het Programma en
zijn doel>

Auteursrecht (C) <jaar> <naam van de
Auteur>

Dit Programma is vrije
software; U kunt het verspreiden en/of wijzigen onder de bepalingen
van de GNU Algemene Publieke Licentie, zoals uitgegeven door de Free
Software Foundation; oftewel versie 2 van de Licentie,of (naar vrije
keuze) een latere versie.

Dit Programma is verspreid met de hoop dat het
nuttig zal zijn maar ZONDER EENDER WELKE GARANTIE; zelfs zonder de
impliciete garantie van VERKOOPBAARHEID of GESCHIKTHEID VOOR EEN
BEPAALD DOEL. Zie de GNU Algemene Publieke Licentie voor meer
details.

U zou een kopie van de GNU Algemene Publieke
Licentie ontvangen moeten hebben samen met dit Programma; indien dit
niet zo is, schrijf naar de Free Software Foundation, Inc., 59 Temple
Place, Suite 330, Boston, MA 02111-1307 USA

Voeg ook informatie bij hoe men
U kunt contacteren via e-mail en gewone post. Als het
Programma interactief is, laat het een korte boodschap tonen zoals
deze wanneer het in interactieve modus start:

Fiscus versie 69, Auteursrecht (C) <jaar>
<naam v/d auteur> Fiscus komt met ABSULUUT GEEN GARANTIE; voor
details typ 'toon w'. Dit is vrije software en het is U toegestaan
deze te verspreiden onder bepaalde voorwaarden;typ 'toon c' voor meer
details.

U zou ook uw werkgever (indien U als programmeur
werkt) of uw school, indien die er is, om een "auteursrecht
afwijzing" te laten tekenen voor het Programma, indien nodig.
Hier is een voorbeeld; wijzig de namen:

Yoyodyne, NV., verwerpt hier alle auteursrechtlijk
interesses in het Programma Fiscus (dat belastingsaangiften invult)
geschreven door James Hacker. <handtekening van Ty Coon>, 21
April 1984 Ty Coon, Vice voorzitter.

Deze Algemene Publieke Licentie laat niet toe dat
het Programma verwerkt wordt in een commercieel programma. Als uw
Programma een subroutine bibliotheek is,dan kunt U
het misschien nuttige beschouwen om toe te staan dat uw Programma
gelinkt word met commerciële programma's. Als dat is wat
U wil doen, dan moet U de GNU Algemene Minder Publieke Licentie
gebruiken in plaats van deze licentie.